Prepar3DV3.3 Patch

  • Hallo!


    Mit der Veröffentlichung von Prepar3V3.3 gab es plötzliche und unvorhergesehene Probleme, diese wurden erkannt und glöst und in einen Patch verarbeitet.


    Diese Szenerien waren betroffen


    - Mülheim Ruhr X v1.11
    - EDRN Nannhausen v1.02
    - Hengsen-Opherdicke v1.00


    Während in Hengsen-Opherdicke und Nannhausen es ausreichte, im Material Editor des P3D-SDK ein Häkchen zu de-aktivieren (double sided) und anschließend das entsprechende 3-D Modell zu exportieren, musste in Mülheim Ruhr X die Befeuerungsablage wieder ans Laufen gebracht werden, was sich als nicht ganz einfach herausstellte.


    Hier ein paar Dinge die mir bei Prepa3D V3.3 aufgefallen waren:


    - Die Positionierung einzelner Objekte war ungenau geworden. Diese Objekte wurden neu positioniert.
    - Probleme mit Objekten deren Textur einen Alphakanal hat.
    - Probleme mit doppeltseitigen Objekten. Hier reichte es, ein kleine Häkchen in den Materialeinstellungen raus zu nehmen.
    - Library-Objekte lassen sich nicht mehr mittels XML-Positionierungsdatei kippen/schrägstelle. Wenn man zum Beispiel ein Lib-Fahrzeug auf ein Gelände mit Gefälle stellen möchte, dann schweben die Räder in der Luft.
    - Offenbar wurden am internen LOD-System Änderungen vorgenommen. In Mülheim funktionierten die Lichter, die auf das interne LOD-System beruht, nicht mehr. Durch einen simplen Trick wurden sie wieder ans Funktionieren gebracht.


    Patch_P3Dv3_3_MuelheimRuhrXv111.zip
    Patch_P3Dv3_3_Hengsen_Opherdicke_v100.zip


    Die Patches sind nicht mehr benötigt, da LM selbst mit dem neuen HOTFIX 3.3.5 alle oben aufgeführten Fehler beseitigt hat.

  • Hi Frank.


    Ich denke die Patches sind überflüssig geworden. Der Hotfix 3.3.5 hat alles korrigiert von dem ich annahm, dass es nicht korrigiert würde. Im Gespräch waren meiner Meinung nur die Probleme mit dem Falckern von Bodenpolygone. Die anderen Fehler wurden nicht thematisiert, weshalb ich dachte, dass das dann auch nicht korrigiert wird. Mein Fehler!


    In meiner Not hatte ich vor Herausgabe des Hotfix von LM selbst an einer Lösung gebastelt :-)


    Um aber ganz sicher zu gehen habe ich Nannhausen, Mülheim und Hengsen-Opherdicke gerade getestet und siehe da, alles funktioniert wieder wie zuvor. Die Lichter in Mülheim gehen wieder, die falsch-Positionierung der animierten Personen ist weg, und die Objekte die auf abschüssigem Gelande stehen (Hengsen-Opherdicke), werden nun auch wieder korrekt dargestellt. Die Objekte mit Alphakanal flackern ebenso nicht mehr als auch die Probleme mit doppelseitigen Objekten korrigiert wurden.


    Vielleicht war ich etwas vorschnell und hätte besser erst auf den Hotfix gewartet und daran dann mögliche Anpassungen ausgerichtet ;-)


    Grüße
    Christian

  • Hallo zusammen.


    Die Patches sind nicht mehr benötigt, da LM selbst mit dem neuen HOTFIX 3.3.5 alle oben aufgeführten Fehler beseitigt hat.


    Christian

Participate now!

Don’t have an account yet? Register yourself now and be a part of Flusiboad!