SODE: Sämtliche Jetways plötzlich weg

  • Hallo zusammen,


    ich habe seit einigen Tagen das Problem, dass meine sämtlichen Sode-Jetways plötzlich verschwunden sind, auf allen entsprechend ausgerüsteten Flughäfen. Muss bei der Installation einer Scenery passiert sein.


    Keine meiner Lösungsstrategien hat bislang gefruchtet. Das waren folgende Maßnahmen bzw. Kontrollen:

    • De- und Neuinstallation von Sode
    • De- und Neuinstallation betroffener Szenerien
    • SimConnect ist installiert
    • die beiden Felder im Platform Manager sind grün (registered, active)
    • in C:\ProgramData\12bPilot\SODE befinden sich Dateien und insb. der Ordner SimObjects mit Unterordnern zu allen Flughäfen
    • die im Platform Manager angegebenen Pfade existieren und enthalten Daten, an denen mir nichts Schlimmes auffällt
    • im P3D4 ist SODE unter Options - Add-Ons gelistet

    Ob die ganzen XML- und DLL-Dateien korrekt arbeiten, kann ich nicht prüfen.


    Bin ein bisschen verzweifelt und für Hinweise dankbar, zumal ich den Eindruck habe, dass es vielleicht eine Kleinigkeit sein könnte. Bisher hat alles tadellos funktioniert.


    Danke und Gruß

    Norbert

  • Hast Du die entsprechende neue Szenerie mal wieder deinstalliert / abgeschaltet?

    Was heißt "verschwunden"? Wenn SODE noch korrekt arbeitet und die Jetways verschwinden, müssten dort rote Fragezeichen auftauchen, wenn die Modelle nicht gefunden werden.

    In den meisten Fällen ist es so, dass - wenn man plötzlich überhaupt nichts mehr sieht - irgendwelche Texturen nicht gefunden werden. Anders als z. B. bei fehlenden Texturen von MDLs/Szenerieobjekten taucht dann plötzlich nix mehr auf - nur Luft.

    Kannst Du vielleicht mal die XML-Datei hier posten?

    Und die LOG-Datei? Dort findet man oft schon Anhaltspunkte, was schief läuft...

  • FrankEDDB

    Added the Label Prepar3D v4
  • Hallo Manfred,


    danke schonmal. "Verschwunden" heißt, dass die Jetways einfach weg sind. Rote Fragezeichen gibt es nicht. Wer nicht weiß, dass es im wirklichen Leben Jetways gibt, für den sieht alles ganz manierlich aus.

    Inzwischen habe ich hier: https://sode.12bpilot.ch/?topic=troubleshoot-guide, Hinweise gefunden. Da im Sode PlatformManager beide Statusfelder grün sind, aber der SODE-Eintrag im P3D4-Menü Add-Ons fehlt, wird "probable a deeper problem with SimConnect" vermutet. Lt. Titelzeile des Sode PlatformManagers ist allerdings SimConnect=OK. Um die tieferen Probleme zu finden, soll man die simconnect.log erzeugen. Die hab ich mit der SODE.log mal hier beigelegt und werde mich wohl auch an den SODE-Support wenden.

    Wenn hier jemand aus diesen kryptischen Texten schlau wird ...


    Danke und Gruß

    Norbert

  • Diese Zeilen hier sind mir in Dienem SODE log aufgefallen:


    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 1A' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 2A' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 2C' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 3A' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 3' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 4B' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 5A' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 5C' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 6A' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 6C' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 7A' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 7C' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 8C Front' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 8C Aft' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 9A' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 9C' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 10A' ignored due to different target sim. [FSX;FSX-SE]!

    [20:23:22.266] INFO SODE.XML : SimObject 'Jetway 10C' ignored due to different target sim. [FSX;FSX-SE]!


    Kann es sein, dass Du bei Deinen Pfaden in den SODE-Optionen bei der Installation eine falsche Pfadangabe gemacht hast, sprich SODE nach einem falschen Sim sucht? Deine Signatur zeigt den P3Dv4, der SODE Target Sim erwähnt den FSX;FSX-SE?

  • Es gibt ja in der SODE.LOG eine ganze Reihe Fehlermeldungen, zumeist auf bestimmte Airport-Szenerien bezogen. Aber auch auf Airports, wo keine Fehler aufgeführt sind, finden sich keine Jetways, was ja auch kein Wunder ist, da SODE insgesamt nicht funktioniert: Im Add-Ons-Menü gibts ja keinen SODE-Eintrag.


    Wo findet man denn diese Jetways 1A bis 10C, so dass man dort nach falschen Pfadangaben suchen könnte? Ich muss sagen, dass ich diese LOG-Files nicht annähernd lesen oder verstehen kann. Außer natürlich, dass Wendungen wie "ERROR", "does not exist" oder "invalid format" vermutlich nichts Gutes verheißen. Aber wie geht man solchen Fehlern nach? Und was hat es zu bedeuten, dass ein Großteil der SODE.LOG aus sich wiederholenden Einträgen zu LFPO und LFPG enthält, gefolgt von Refreshing Season/Time Data...


    Ich habe die Fehlerbeschreibung auch im Sode Support Forum gepostet. Leider bislang keine Antwort.


    Viele Grüße

    Norbert

  • Also was ich spontan vermute, ist, dass Deine Jetways von SODE nicht berücksichtigt werden. Ich nehme an, dass diese Jetway-Modelle in allen Szenerien verwendet werden, in denen sie nicht auftauchen.

    Neu ist für mich Dein Hinweis, dass SODE allgemein nicht funktioniert? Dann können die Jetways natürlich auch nicht auftauchen...


    Daher zu allererst einmal: Erscheint bei Dir im P3Dv4 in der oberen Menü-Zeile unter "Addons" ein SODE-Eintrag? Wenn ja, dann läuft das Programm selbst ordnungsgemäß, kann aber auf die Modelle nicht zugreifen...

    Welche Szenerie hast Du installiert und:

    1. Ist diese Szenerie eine P3Dv4-Szenerie oder eine FSX/FSX-SE-Szenerie?

    2. Enthält diese Szenerie SODE-Elemente (wahrscheinlich, vielleicht gibt es deswegen Beef mit den anderen SODE-Einstellungen...)?


    Aus Deiner SODE-Log meine ich zu erkennen, dass SODE eigentlich takko arbeitet und auch den P3Dv4 erkennt:


    [20:23:22.175] INFO : SODE Version 1.6.5

    [20:23:22.175] INFO : Targetting Platform 'P3Dv4'

    [20:23:22.176] DEBUG SODE.SETTINGS : All Settings successfully read.


    Dein SODE scheint alle relevanten Modelle (von Just Sim bis UK200) zu finden, aber wenn es zum Debuggen (also Austesten) der o. a. Jetways kommt, schreibt das LOG:


    SimObject 'Jetway 9A' ignored due to different target sim. [FSX;FSX-SE]!


    Das heißt, dass SODE die Zugriffe ignoriert, weil diese auf eben den FSX/FSX-SE verweisen.


    Daher nochmal meine Frage: Warum will SODE auf FSX-Pfade zugreifen, die es augenscheinlich nicht gibt?


    Einzige plausible Erklärung ist, dass eben die neu installierte Szenerie eine FSX/FSX-SE-Szenerie ist, die vielleicht per Autoinstaller installiert wurde und die entsprechenden Störeinträge in Dein SODE gepflanzt hat.

    Liest SODE nun mögliche durch die neue Szenerie hineingeschriebenen Jetway-Daten, die auf den FSX verweisen, dieser aber nicht vorhanden ist, macht SODE es sich einfach und ignoriert eben diese Modelle...


    Erste Abhilfe-Maßnahme wäre, falls per Autoinstaller installiert, diese zu deinstallieren und schauen, ob die Jetways wieder da sind.


    Gib mal bescheid, wenn's nicht klappt, tüfteln wir weiter...

  • Danke für Dein Nachdenken über mein Problem. Also im Menü "Add-Ons" taucht kein SODE-Eintrag auf. Im Menü "Options - Add-Ons" ist SODE hingegen gelistet. Und der SODE Platform Manager zeigt ja auch beide Statusfelder grün und meldet alles ok, auch SimConnect. Ich habe inzwischen viele meiner zahlreichen Szenerien geladen, um zu schauen, ob Jetways da sind. Nein, sind alle weg, überall. Auch da wo es monatelang einwandfrei geklappt hat.


    Ich habe auch die zuletzt neuinstallierten Szenerien wieder deinstalliert. Ob dadurch eine evt. zerschossene SODE-Konfiguration wieder geheilt würde, ist natürlich fraglich, auf jeden Fall gab es keinen positiven Effekt.


    Gedanklich freunde ich mich allmählich mit dem Gedanken an, den P3D komplett platt zu machen und neu zu installieren. Was natürlich extrem aufwändig wäre.


    Viele Grüße, Norbert

  • Vorher würde ich mal die bestehende prepar3d.cfg sichern (in z. B. prepar3d.AUS) und dann vom P3D beim Neustart eine neue erstellen lassen. Vielleicht räumt das ja schon wieder etwas auf - oft zeigt das kleine Wunder...

    Bring uns dennoch mal auf den aktuellen Stand, ob und/oder wie Du FSX installiert hast/hattest. Denn da würde ich reflexartig die Ursache suchen.

    Und ist die neue Szenerie eine FSX-Szenerie?

  • Hallo zusammen,


    da ich dann auch Probleme mit ChasePlane bekam, das möglicherweise auch mit SimConnect arbeitet, habe ich in den sauren Apfel gebissen und den P3D mit sämtlichen Addons deinstalliert und neuinstalliert. Vielleicht hätte ich Windows plattmachen sollen und die Windows- und Flusifestplatten formatieren sollen, denn ich sehe weiterhin keine SODE-Jetways, und den SODE-Eintrag im Addon-Menü des P3D auch nicht. ChasePlane läuft wieder, und ich kann fliegen, aber das Gefühl ist nicht so gut, da ja ggf. nicht nur die Jetways fehlen, sondern auch anderes, was SimConnect so macht - Windsocks, Jahreszeiten ..., so genau weiß ich gar nicht, wofür SimConnect alles zuständig ist.


    SODE kann man ja auch von Orbx Central aus installieren. Hier de- und reinstallieren hat aber auch nichts gebracht.


    Jetzt bin ich etwas ratlos, vertreibe meine Zeit mit ein paar VFR-Flügen. Sollte ich demnächst in Coronaquarantäne müssen, werde ich das gesamte Windows-System neu aufsetzen und anschließend berichten.


    Danke für Eure Hilfe. Gruß, Norbert

Participate now!

Don’t have an account yet? Register yourself now and be a part of Flusiboad!