Autogen und Texturen laden mit ORBX Produkten langsamer / gar nicht nach

  • Ich mache jetzt mal einen neuen Thread auf, es hat ja definitiv nichts mehr mit neuer Hardware zu tun, basiert aber auf diesen hier:

    Hilfe für Prozessor-Upgrade gesucht


    Vorab mein System:

    500 Watt beQuiet Netzteil

    intel i5 9600k @ 4.8GHZ

    32 GB DDR 4 RAM (Corsair Vengeance)

    ASUS Z390A Motherboard

    Samsung SSD 1TB

    Gainward 1060 mit 6GB RAM


    P3D Einstellungen:

    Nach dem Guide von Simmershome, meistens nichts höher als die zweithöchste Stufe. Teilweise darunter.


    Nun zum "Problem" mit dem "nackten" P3D habe ich es irgendwann hinbekommen dass das Autogen knackig und recht zügig nachlädt. Auch der Ladevorgang bevor man im Cockpit sitzt ist mit der SSD recht flott gewesen. Also alles akzeptabel. Wenn man dann mit einem Airbus runter aus dem Wolken gekommen ist hat man zwar das nachladen gesehen, aber das war ja noch ok.


    Nachdem das nun "gelöst" war habe ich ORBX installiert, Global, Vector und open LC EU und schon sind die Probleme wieder da. Mit Germany North und South sogar noch schlimmer! Das laden dauert ewig und ich habe wirklich alles auf einen halbwegs vernünftigen SSD liegen. Ich fliege los, ich fliege - egal mit welcher Geschwindigkeit, aus dem vorgeladenen Kreis heraus und dann fehlt erst das Autogen und dann werden irgendwann die Texturen matschig.


    Ich frage mich nur woran das liegt. Kann dann ja nur am Nachladen und den größeren Dateien liegen oder ORBX hat da irgendeinen Mist gebaut. Schneller als einer SSD kann ja nichts mehr nachladen. Die Einstellungen sind nicht übertrieben! Der Rechner hat genug Leistung. Er überhitzt auch nicht oder irgendwas. Trotzdem lädt irgendwann nichts mehr nach bzw. zu langsam. Wenn ich nämlich die Kamera drehe, sehe ich sehr wohl das hinter dem Flugzeug was lädt und geladen hat.


    Es ist dabei auch egal ob ich intern oder extern auf 30 FPS begrenze oder mit VSYNC auf 60 FPS laufen lasse.


    Warum ist das so? Wieso kann der Sim nicht einfach vorberechnen wo ich gleich sein werde und halt die 10km vor meiner Nase nachladen und nicht das was sowieso hinter mir liegt. Eigentlich müsste er ja davon ausgehen das ich meine Richtung um nicht mehr als 180° ändere und dann dementsprechend in diesem Bereich zuerst nachladen und nicht Stur da wo ich sowieso gerade lang geflogen bin. Es hieß auch schond as LM dieses Problem nicht straff genug angehen würde.


    Vor dem 64 bit System hatte ich dieses Problem nicht - auf noch einen viel älteren Rechner. Da waren immer nur die 4GB halt ein Thema was ab und an mal aufpoppte. Aber die ganzen ORBX Sachen oder das nachladen waren kein Thema - es hat da zwar auch ein gutes Stück gedauert ehe man im Cockpit war, aber es hat funktioniert. Das macht doch so keinen Spaß... haben die Leute die dieses Problem nicht haben einfach kein ORBX?


    Ich mein... ich kann jetzt auch einfach auf alles bis auf Global und die HD Textures und Trees verzichten - also auf Vector und open LC, Germany. Aber das ja dann auch nicht Sinn der Übung in einem doch recht tristen P3D herum zu fliegen.


    Vielleicht habt ihr ja noch eine Idee.

  • Ich aus meinen Erfahrungen kann nur sagen, ein glückliches Betreiben des Flusis mit GEN/GES ist unmöglich - es sei denn, Du hast einem Lottogewinn gleich eine der wenigen Einstellungen erwischt, die das zulassen - aber meist auch nur mit Einschränkungen, sprich diverse Regler niemals auf Maximum.


    Und mit Einstellungen meine ich nicht die paar Regler, die Dir P3D zur Verfügung stellt. Es geht vielmehr um das komplexe Zusammenspiel von GraKa (z. B. nVidia-Einstellungen). Schon hast Du eine Gleichung mit 2 Unbekannten.

    Dazu kommen andere Programme, die auf Deinem PC laufen - 3 Unbekannte.

    GEN/GES sind m. E. die Hauptzerstörer des normalen Flusi-Spaßfaktors. Wohl zuviel gutgemeinte POIs und Objekte, die beim normalen OpenLC EU nicht vorhanden sind, überfordern die meisten Systeme, die ebenfalls im normalen Alltag noch andere Dienste verrichten sollen.

    Desweiteren erscheint es mir, als wenn ORBX und P3D nicht miteinander harmonieren (da können Experten sicherlich noch detaillierter antworten).

    Noch im FSX (und ja, ich bin davon überzeugt, dass tweaken im gewissen Rahmen geholfen hat...) war es möglich, nach gefühlt Wochen endlich eine Einstellung zu finden, bei der man mit einem Jet mit 400kn in 3000 Fuß über NRW fliegen konnte, ohne dass etwas verschwamm oder Autogen den Dienst quittierte. Man musste Einbußen bei den Frames hinnehmen, aber wenn Du auf 20 FPS gelockt hast, hattest Du +-5 Frames immer noch halbwegs eine gute Darstellung von Bewegung.

    Natürlich kommt P3D - vor allem ab v4 - mit ordentlichen Verbesserungen daher, nicht zuletzt mit der 64bit-Wundertüte. Generell schon ab früheren Versionen die Schattenwürfe, die im Gegensatz zum FSX nun realistisch auf allen Objekten abgebildet werden.


    Aber nehme ich eine annähernd ähnliche Einstellung wie damals beim FSX und locke bei z. B. 20 Frames, geht meine Performance dennoch runter bis auf 12, teilweise sogar 1-stellig.


    Deaktiviere ich GEN/GES, habe ich schlagartig 25 - 30 Prozent mehr Frames und fliege ich nicht über Ballungsgebiete, kann ich den Throttle auch bei einer Lightning bis an den Anschlag gehen, ohne dass was verschwimmt oder nicht nachlädt (bei moderaten Einstellungen im P3D als Grundlage...).

    Das bedeutet allerdings, dass ich im schlimmsten Fall bei 15 Frames kaum AI haben darf, meist wolkenloser Himmel herrschen muss, die Welt fast ohne Schatten auskommen muss und ich gewissenhaft im Task-Manager vorher alles abstelle, was mir während eines Fluges das Erlebnis versauen könnte.


    Bin kein Mathematiker, aber die Variablen, die Dir Dein Flusierlebniss boykottieren können, sind immens hoch. Da kann Dir auch jemand sagen, dass bei ihm alles fantastisch funktioniert - tut's bei manchen Körpern aber auch, obwohl die Personen rauchen, trinken und Zucker tonnenweise in sich reinschaufeln, nachdem sie fünf Bürger verdrückt haben und immer noch einen Schatten wie eine Straßenlaterne werfen.

    Andere hingegen machen ja alles "richtig" - gesunde Ernährung, WeightWatchers Dauerabo, Zucker nur mal beim Briefmarkenschlecken und mindestens einen Halbmarathon in der Woche. Aber leck mich fett - die Plauze bleibt, die Variablen im Organismus scheinen irgendwie die Gleichung nicht richtig zu packen...

    Will schreiben: Bei manchen (oh, m. E. sehr wenigen...) funzt's, bei anderen (m. E. die meisten...) nicht. Auch, wenn das Zusammenspiel von Flusi, Addons, PC-Programmen, leistungsrelevanter Hardware, deren abgestimmtes Verhalten der Einstellungen untereinander nicht so komplex sein kann wie ein menschlicher Körper - GEFÜHLT IST ES TROTZDEM SO.


    Mein Fazit: Entweder Du hast Glück, oder Du hast Pech.

    Oder Du verschwendest wertvolle Lebenszeit (spreche leider aus Erfahrung...) mit der unerfüllten Hoffnung durch endlose Einstellungsversuche den heiligen Flusigral zu entdecken.

    Oh, als Trost: An Deinem System liegt es bei Weitem nicht, dass Du diesen Horror hast - obwohl die GraKa mit 6 GB vielleicht ein wenig mau wirkt für ein prefektes Kunsterlebnis. Nichtsdestotrotz sollten auch mit einer 1060er keine Blurries entstehen und das Autogen sich gefälligst zum Dienst melden...

  • Ich aus meinen Erfahrungen kann nur sagen, ein glückliches Betreiben des Flusis mit GEN/GES ist unmöglich - es sei denn, Du hast einem Lottogewinn gleich eine der wenigen Einstellungen erwischt, die das zulassen - aber meist auch nur mit Einschränkungen, sprich diverse Regler niemals auf Maximum.

    Das stimmt, allerdings komme ich mit recht hohen Einstellungen (zumindest trüben sie nicht den Eindruck) recht gut klar, sogar in Berlin

    England Raum London kann man allerdings in die Tonne drücken, wenn man auch noch UK 2000 hat.

    Norwegen geht hingegen problemlos.

    In den USA habe ich eigentlich außer in extremen Ballungsräumen auch keine Probleme. Das Nachladeproblem habe ich nicht.


    Wichtig wäre noch Global Terrain View ( UseGlobalTerrainView=True) zu setzen. Standard ist False. Lässt man dies so lädt der Sim für jede Kameransicht eine eigenen Terrainansicht, was natürlich auch Nachladeerscheinungen bewirken kann.

    Und wer dann das Problem sowieso schon hat kann die AutogenDrawDistance nie höher als middle setzen. Alles Andere ist Wunschdenken.

    Dazu im Standardflug die Sicht auf 48 Meilen setzen (man sieht eh selten real weiter ) und das ganze sollte auch auf einem mittleren System annehmbar laufen.


    OrbX bleibt trotzdem OrbX , so sind sie halt. Performance war noch nie deren Stärke

  • Auf GEN N und S kann ich verzichten. Die Open LC Variante und einige "Mega Airports" sollte der Sim aber schon verkraften. Das wäre jedenfalls mein Anspruch. Ich habe auch jetzt noch mal die .cfg neu erzeugen lassen. Es wird nicht besser. Selbst wenn die Regler noch weiter unten sind.


    Irgendwann wird einfach gar kein Autogen mehr nachgeladen. Ich begreife wirklich nicht wieso das so ist. Es läuft ja kein Wert irgendwo ins Maximum es lädt einfach nicht nach.


    Ich hatte das ja früher auch schon. Aber da habe ich es auf den etwas schwächeren Prozessor geschoben und zu wenig RAM.


    Was kann ich noch tun? Es muss doch irgendeinen Weg geben...

    Glaube fast das es besser ist wenn ich zum FSX oder zu P3D v3 zurück gehe. Da lief ja alles... sogar nur mit 4GB RAM addresierbaren Speicher.

  • Wichtig wäre noch Global Terrain View ( UseGlobalTerrainView=True) zu setzen. Standard ist False. Lässt man dies so lädt der Sim für jede Kameransicht eine eigenen Terrainansicht, was natürlich auch Nachladeerscheinungen bewirken kann.

    Wap? Kannte ich noch gar nicht, muss ich heute nachmittag mal gleich probieren, da ich sehr gern mit meinen Ansichten rumspiele. Mal Cockpitsicht, dann wieder, wenn ich mich beim VFR verflogen habe, wieder in Außenansicht. Guter Hinweis...

    Bleibt die Einstellung dann auch so, oder ist das eine der Einstellungen, die ich jedesmal wieder vor dem Start des P3D erneut machen muss?

  • Ich bin jetzt auf die v3 zurück gegangen. Da lädt das Autogen knackig nach, in höheren Einstellungen als ich es in der v4 drinne hatte und ohne Tweaks. Das macht halt keinen Sinn - ich verstehe es nicht.


    Begreife nicht wieso ich mit der v4 so Porbleme habe...

  • Okay, wenn v3 bei Dir plötzlich wieder problemlos läuft, sehe ich das Problem tatsächlich in der Nutzung des Systems unter 64bit. Kann uns hier ein Fachmann vielleicht ein wenig Aufklärung bescheren?

    Das würde auch erklären, warum bei mir damals mit dem FSX unter 32bit ein halbwegs spaßiger Flusigenuss zustande kam und ich ebenfalls mit dem v4 keine matschfreien und autogenfreundlichen Flüge erlebe (vergleiche deshalb zwischen FSX und P3Dv4, weil ich direkt vom FSX auf den v4 umgestiegen bin....)


    Noch nie darüber nachgedacht, aber dann scheint auf einigen Systemen tatsächlich ein Problem mit der 64bit-Verwaltung zu bestehen!!!!

    Das ergäbe Sinn und vielleicht einen neuen Ansatzpunkt!!!

    Gerade, weil meine Vermutung, warum manche überhaupt keine Probleme, andere wiederum NUR Probleme mit dieser Misere haben!!!

    (Sorry für die vielen Ausrufezeichen, aber ich glaube, das ist mal ein neuer Ansatz...)

Participate now!

Don’t have an account yet? Register yourself now and be a part of Flusiboad!